【Windows10】システム通知音でノイズが混入する不具合。原因は意外なところに…

記事内広告PC

WindowsUpdateの不具合、多すぎますねー。

最近のWindowsUpdateでは インターネットエクスプローラー11 のGoogleツールバーの不具合で悩まされましたし、今回のサウンド関連のトラブルも散々悩まされました。

具体的な症状は、

・音楽や動画の再生中にWindows10のシステム通知音が鳴ると、左チャンネルに「ザザザザ」とノイズが混入する。

この音です。

一旦ノイズが発生してしまうと、それ以降は動画や音楽再生時の左チャンネルの音声が常にノイズまみれになってしまいます。

いったい真犯人は誰なんですかいのぉ?

自室で使用中のD/Aコンバータ内臓アンプ SU-MA10の電源を一度切って入れなおすと正常に復帰するのですが、ということは、入力側と出力側でうまく同期が取れていないという事です。
いったい原因は何なのか考えてみました。

・接続している光ファイバーケーブルの不具合
・Realtek HD オーディオドライバのバグ
・アンプ側の光入力端子がぶっ壊れた?それともアンプ内のD/Aコンバータがお亡くなりに?
・アンプ側で公式にサポートしていない24ビット出力が原因?
・パソコンの光出力端子が逝っちゃった?
・Windows10のバグ?

考えられる要因としては、こんなところでしょう。
お金の掛からないところから、ひとつづつ探っていきました。

ちなみにRealtek HD オーディオマネージャの設定はこうでした。

まず、アンプの光入力を別端子に接続してもダメでした。
パソコン側で16ビット出力や44.1KHzでの出力も試したのですが、これも症状は改善しません。
アンプの電源を入れなおすと正常に復帰するということは、サンプリングレートの同期が取れていないということでしょうから、パソコン側からの出力に問題がありそうですね。

しかしながら、Realtek HD オーディオドライバを最新に更新してもダメでしたし、さんざんググってみても「これだっ!」というものに巡り合えません。

「これはもう、光ファイバーケーブルそのものかもしれんね」

そう思って、Amazonでハイレゾ対応の光ファイバーケーブルをポチってしまいました。
ケーブル到着後、「これで解決やな」とウキウキしてテストしてみたのですが…

全く症状は改善しませんでした!

「ゴルァァァ!どないなっとんじゃぁぁぁー!」
「Windowsっ!おまえかっ!おまえやなっ!」

またいつものWindowsUpdateのバグか?
次のアップデートを気長に待つしかないのか?
と思っていた僕の脳裏に、まるでニュータイプのように閃光が走りましたっ!

「そういえば、Windows自体にもサウンドの出力フォーマットを設定する箇所が有ったよな!」
そう、これがまさに、ビンゴ!だったのです。

記事内広告PC

Windows10さん… 真犯人はあなた… ですね。

コントロールパネルの「ハードウェアとサウンド」から、

「オーディオデバイスの管理」を選択すると、

現在の出力デバイスが表示されますので、プロパティをクリックします。

なんとビックリ!( ゚д゚)
サンプルレートの「44.1KHz」にチェックが入っていないじゃないですかっ!
当然再生できますって!!

「44.1KHz」にチェックを入れてテストしましたら、今回のこの不具合が嘘のように直ってました。
いや、仮に「44.1KHz」にチェックが入っていない状態でも、ノイズが入っちゃダメでしょ!
サンプリングレートコンバータ何やってんの!

これは立派にWindows10のバグです!

ゴルァァァ!マイク〇ソフトォ!
光ファイバーケーブルの金返せぇぇぇー!!
温厚なワシでも、たいがいキレるでぇ!!!

というわけで一件落着いたしました。
もしも同じ症状に悩まされている方がいらっしゃったら、参考になりましたら幸いです。

PS.
マ〇クロソフトに対する怒りは何とか静まりました。
やっぱり、いつまでも怨みの気持ちを持ち続けるのって良くないですよねー。

記事内広告PC

追記:

ああああぁぁぁー!!
またノイズが発生してしまいましたぁぁぁー!!
ずっと正常に動いていたのにぃぃぃー。

何かのタイミングでWindows10のサンプリングレートコンバータ?がバグってしまうようですね…
次のWindowsUpdateで直っていればいいのですが…

とりあえず、システムのサウンド設定を「サウンドなし」にして対処しました。

さらに追記:

どうやら「ラウドネス等化」が原因のようです。
これをOFFにして以降は、今のところノイズは発生していません。

さらにさらに追記:

間違いなく「ラウドネス等化」が原因です!
Realtek HD オーディオドライバの2016年6月リリース版をずっと使い続けていて、2017年の3月下旬から急にノイズが発生するようになったということは、その頃のWindowsUpdateが原因のようです。

どうやら「ラウドネス等化」はサウンドチップによるハードウェアでの実装ではなく、Windows側でソフトウェア的に実装しているようですから、どこかのタイミングで「ラウドネス等化」のアルゴリズムを変更したものと思われます。

これは間違いなくWindows10のバグです!

ゴルァァァ!マイクロ〇フトォ!
最近バグばっかりやないかい!!
ちっとはグー〇ルを見習わんかい!!!

さらにさらにさらに追記:

なんと!「ラウドネス等化」オフでもノイズが発生してしまいました。

いったい原因は何なのか?
ほとほと疲れ果てました…
トホホ…

記事内広告PC
関連コンテンツ ユニット
関連コンテンツ

シェアして頂けたら嬉しいです!

記事内広告PC

コメント

  1. mmdisk より:

    やまねこさん
    初めまして@mmdiskです。
    私のPCも同様の問題が発生しています。XP時代のマザー(G41M)にwin10を載せてる機械です。
    症状は、cpu使用率が低い場合のオーディオ再生にブツブツ音が発生する割合が多い様です。
    Netに色々対応が書かれていますが、一つだけ症状が治る選択がありました。
    電源プランです。通常「バランス(推奨)」を選択していますが、「高パフォーマンス」に変更するときれいにノイズがなくなりました。ただし「低パフォーマンス」でも
    同様の改善があります。何の設定が違うか良くわかりませんが?
    ご参考までに。

    • やまねこ より:

      mmdiskさん、コメント頂いてありがとうございます。

      貴重な知見をお教えいただきましてありがとうございます。
      追記していないんですが、実はこの記事の件は解決しておりまして、原因は使用しているアンプのスピーカー端子の不良でした。

      やっと解決してほっと一息ついていたところ、今度はこの春の大規模アップデートで無線LANはブツブツ切れるは、またまた音もブツブツ途切れるはで、えらい目にあいました。

      原因は、USBのセレクティブサスペンドが有効になっていた事と、realtek hd オーディオマネージャーが原因でした。
      USBのセレクティブサスペンドを無効にすることで無線LANのトラブルは解消し、realtek hd オーディオマネージャーをアンインストールして、ドライバーのみを再インストールすることで音の件は解決しました。

      このところ、この記事のアクセスが急上昇していますので、もしかしたら同じ症状でお悩みの方が多いのかもしれません。

  2. core-i8 より:

    新しく買ったPCのシステムサウンドが雑音だらけだったため困惑していました。
    設定を16bitや32bitにすると雑音が消えてくれました。
    なぜ24bitだけに雑音が発生するのか謎です。

    • やまねこ より:

      core-i8さん、コメント頂いてありがとうございます。

      パソコンを使ってると、往々にしてそのような意味不明の現象に悩まされますよね。
      ドライバのバグだったり、Windowsのアップデートが原因だったりで、ググってみてもなかなか「これだ!」という記述が見つからなかったりで苦労させられます。

      Windows10になってからはだいぶマシにはなったと思うのですが…